summaryrefslogtreecommitdiff
path: root/Cargo.toml
diff options
context:
space:
mode:
authoriximeow <git@iximeow.net>2022-12-22 18:29:26 +0000
committeriximeow <git@iximeow.net>2022-12-22 18:29:26 +0000
commit4a213e872395f9b0562c113bb7303815a1d26a57 (patch)
tree568464060736a76ae72337d531ac65c95192e48c /Cargo.toml
parent7734472faa9e0ecb18bab286055aceaa13c9c947 (diff)
draw almost all of the owl
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml13
1 files changed, 13 insertions, 0 deletions
diff --git a/Cargo.toml b/Cargo.toml
index 832d81f..1ac1665 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -16,6 +16,9 @@ serde_derive = "*"
serde_json = "*"
rand = "*"
tokio = { version = "*", features = ["full"] }
+tokio-stream = "*"
+hyper = "*"
+futures-util = "*"
tracing = "*"
tracing-subscriber = "*"
http-body = "*"
@@ -25,6 +28,8 @@ hmac = "*"
hex = "*"
sha2 = "*"
reqwest = { version = "*", features = ["rustls-tls-native-roots"] }
+clap = { version = "*", features = ["derive"] }
+rlua = "*"
[[bin]]
name = "ci_webserver"
@@ -33,3 +38,11 @@ path = "src/main.rs"
[[bin]]
name = "ci_driver"
path = "src/ci_driver.rs"
+
+[[bin]]
+name = "ci_ctl"
+path = "src/ci_ctl.rs"
+
+[[bin]]
+name = "ci_runner"
+path = "src/ci_runner.rs"