summaryrefslogtreecommitdiff
path: root/Cargo.toml
diff options
context:
space:
mode:
authoriximeow <git@iximeow.net>2022-12-04 21:07:57 +0000
committeriximeow <git@iximeow.net>2022-12-04 21:07:57 +0000
commit7734472faa9e0ecb18bab286055aceaa13c9c947 (patch)
treeb659eda3d42aeb6ac993a648458f852330d97ca5 /Cargo.toml
add ci driver, webserver. they work.
"work" is a strong word.
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml35
1 files changed, 35 insertions, 0 deletions
diff --git a/Cargo.toml b/Cargo.toml
new file mode 100644
index 0000000..832d81f
--- /dev/null
+++ b/Cargo.toml
@@ -0,0 +1,35 @@
+[package]
+name = "ixi-ci-server"
+version = "0.0.1"
+authors = [ "iximeow <me@iximeow.net>" ]
+license = "0BSD"
+edition = "2021"
+
+[dependencies]
+# warp = { version = "*", features = ["tls"] }
+axum = { version = "*" }
+axum-server = { version = "*", features = ["tls-rustls"] }
+handlebars = "*"
+libc = "*"
+serde = "*"
+serde_derive = "*"
+serde_json = "*"
+rand = "*"
+tokio = { version = "*", features = ["full"] }
+tracing = "*"
+tracing-subscriber = "*"
+http-body = "*"
+rusqlite = "*"
+http = "*"
+hmac = "*"
+hex = "*"
+sha2 = "*"
+reqwest = { version = "*", features = ["rustls-tls-native-roots"] }
+
+[[bin]]
+name = "ci_webserver"
+path = "src/main.rs"
+
+[[bin]]
+name = "ci_driver"
+path = "src/ci_driver.rs"