summaryrefslogtreecommitdiff
path: root/ci-lib-web/Cargo.toml
diff options
context:
space:
mode:
authoriximeow <me@iximeow.net>2023-07-17 23:03:29 -0700
committeriximeow <me@iximeow.net>2023-07-17 23:03:29 -0700
commit128bc8d1146c6c9553ac6c5185e21e00ddcc6829 (patch)
tree902606b0471c3cf30f5c6c20ffd6e3e0f2a62cb4 /ci-lib-web/Cargo.toml
parentcbe41fb33d06410b71a6ae716d6baf14bccaf103 (diff)
start factoring out web view rendering
Diffstat (limited to 'ci-lib-web/Cargo.toml')
-rw-r--r--ci-lib-web/Cargo.toml15
1 files changed, 15 insertions, 0 deletions
diff --git a/ci-lib-web/Cargo.toml b/ci-lib-web/Cargo.toml
new file mode 100644
index 0000000..d6c1acc
--- /dev/null
+++ b/ci-lib-web/Cargo.toml
@@ -0,0 +1,15 @@
+[package]
+name = "ci-lib-web"
+version = "0.0.1"
+authors = [ "iximeow <me@iximeow.net>" ]
+license = "0BSD"
+edition = "2021"
+description = "shared code supporting web views of state.db"
+
+[lib]
+
+[dependencies]
+ci-lib-core = { path = "../ci-lib-core" }
+serde = { version = "*", features = ["derive"] }
+rusqlite = { version = "*", features = ["bundled"] }
+chrono = "*"