summaryrefslogtreecommitdiff
path: root/ci-runner/Cargo.toml
diff options
context:
space:
mode:
authoriximeow <me@iximeow.net>2023-10-29 13:08:37 -0700
committeriximeow <me@iximeow.net>2023-10-29 13:14:32 -0700
commitdb4c638182d1c6b15bdc8d94f7baa691197e9a56 (patch)
tree8fb0ae2a00a0f1f2f3c9a2ce08f770da14acf15e /ci-runner/Cargo.toml
parent6c5f395978b34e7b4626ea8605f0eca20ab730d8 (diff)
split runner into local/remote logic
ideally `trait Runner` describes whatever should have behavioral differences when a task is run locally vs in conjunction with a remote server. then everything consuming a `dyn Runner` will not need to change. if i've done it right.
Diffstat (limited to 'ci-runner/Cargo.toml')
-rw-r--r--ci-runner/Cargo.toml1
1 files changed, 1 insertions, 0 deletions
diff --git a/ci-runner/Cargo.toml b/ci-runner/Cargo.toml
index 038ed14..c956fb5 100644
--- a/ci-runner/Cargo.toml
+++ b/ci-runner/Cargo.toml
@@ -13,6 +13,7 @@ path = "src/main.rs"
ci-lib-core = { path = "../ci-lib-core" }
ci-lib-native = { path = "../ci-lib-native" }
+async-trait = "*"
libc = "*"
serde = "*"
serde_derive = "*"