summaryrefslogtreecommitdiff
path: root/ci-wasm-frontend/Cargo.toml
diff options
context:
space:
mode:
authoriximeow <me@iximeow.net>2023-10-19 08:31:39 -0700
committeriximeow <me@iximeow.net>2023-10-19 08:31:39 -0700
commit6c5f395978b34e7b4626ea8605f0eca20ab730d8 (patch)
treefd7842fde6cd46342397646c40336d09c8fc8d46 /ci-wasm-frontend/Cargo.toml
parent8f6da5586401cb60cfb73b5c74a2152afa3ddbfb (diff)
use shiny hostcall to get cache objects as file descriptors
Diffstat (limited to 'ci-wasm-frontend/Cargo.toml')
-rw-r--r--ci-wasm-frontend/Cargo.toml5
1 files changed, 4 insertions, 1 deletions
diff --git a/ci-wasm-frontend/Cargo.toml b/ci-wasm-frontend/Cargo.toml
index 6acbf49..a840d61 100644
--- a/ci-wasm-frontend/Cargo.toml
+++ b/ci-wasm-frontend/Cargo.toml
@@ -6,7 +6,7 @@ license = "0BSD"
edition = "2021"
[[bin]]
-name = "ci_wasm_frontend"
+name = "ci-wasm-frontend"
path = "src/main.rs"
[dependencies]
@@ -23,3 +23,6 @@ libc = "*"
[patch.crates-io]
rusqlite = { version = "0.26", git = "https://github.com/rkusa/rusqlite.git", branch = "wasi" }
libsqlite3-sys = { version = "0.23", git = "https://github.com/rkusa/rusqlite.git", branch = "wasi" }
+
+[build.release]
+lto = "full"