summaryrefslogtreecommitdiff
path: root/ci-wasm-frontend/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'ci-wasm-frontend/Cargo.toml')
-rw-r--r--ci-wasm-frontend/Cargo.toml25
1 files changed, 25 insertions, 0 deletions
diff --git a/ci-wasm-frontend/Cargo.toml b/ci-wasm-frontend/Cargo.toml
new file mode 100644
index 0000000..6acbf49
--- /dev/null
+++ b/ci-wasm-frontend/Cargo.toml
@@ -0,0 +1,25 @@
+[package]
+name = "ci-wasm-frontend"
+version = "0.0.1"
+authors = [ "iximeow <me@iximeow.net>" ]
+license = "0BSD"
+edition = "2021"
+
+[[bin]]
+name = "ci_wasm_frontend"
+path = "src/main.rs"
+
+[dependencies]
+fastly = "*"
+fastly-shared = "*"
+fastly-sys = "*"
+ci-lib-core = { path = "../ci-lib-core" }
+ci-lib-web = { path = "../ci-lib-web" }
+rusqlite = { version = "0.26", features = ["bundled", "wasm32-wasi-vfs"] }
+sqlite-vfs = "*"
+rand = "*"
+libc = "*"
+
+[patch.crates-io]
+rusqlite = { version = "0.26", git = "https://github.com/rkusa/rusqlite.git", branch = "wasi" }
+libsqlite3-sys = { version = "0.23", git = "https://github.com/rkusa/rusqlite.git", branch = "wasi" }