diff options
author | iximeow <me@iximeow.net> | 2020-01-15 01:14:50 -0800 |
---|---|---|
committer | iximeow <me@iximeow.net> | 2020-01-15 01:14:50 -0800 |
commit | 894cba0dde913d86472430eae8b7ba0353711b4e (patch) | |
tree | 3c0f4eea33a8c0c1db60a1d843cd72702a7be633 /Cargo.toml | |
parent | f0869a1e2fbbdc50f6b020f088da020463e177da (diff) |
no_std!!
this makes yaxpeax-arch no_std. generally nothing has changed w.r.t
downstream crates, but a lot to do with colorization has been moved
tweaked to make it no_std-friendly (specifically, allowing `termion` to
be an optional dependency)
this also makes address parsing optional, in the hopes that decode-only
use cases don't need to involve as much machinery when building.
Diffstat (limited to 'Cargo.toml')
-rw-r--r-- | Cargo.toml | 14 |
1 files changed, 9 insertions, 5 deletions
@@ -10,16 +10,20 @@ repository = "https://git.iximeow.net/yaxpeax-arch/" version = "0.0.1" [dependencies] -"num-traits" = "0.2" -"termion" = "1.4.0" -"serde" = "1.0" +"num-traits" = { version = "0.2", default-features = false } +"termion" = { version = "1.4.0", optional = true } +"serde" = { version = "1.0", optional = true } [profile.release] lto = true [features] -default = [] +default = ["use-serde", "colors", "address-parse"] # enables the (optional) use of Serde for bounds on # Arch and Arch::Address -use-serde = [] +use-serde = ["serde"] + +colors = ["termion"] + +address-parse = [] |