diff options
author | iximeow <me@iximeow.net> | 2024-06-22 11:03:43 -0700 |
---|---|---|
committer | iximeow <me@iximeow.net> | 2024-06-22 11:03:59 -0700 |
commit | a66be66c22bc31526ac35c1cffdb28992a392ccf (patch) | |
tree | 6f49a2e49114256121d3239c2d7223cf635d3c9e /Cargo.toml | |
parent | c21a5f2956d8e0fa3eace14661a8aed124c6e995 (diff) |
move DisplaySink code out from yaxpeax-x86
it was built in-place around yaxpeax-x86, hoisted out once it seemed
suitable and could be generalized. yay!
also include a Makefile in yaxpeax-arch now to test that various crate
feature flag combinations.. work.
Diffstat (limited to 'Cargo.toml')
-rw-r--r-- | Cargo.toml | 6 |
1 files changed, 4 insertions, 2 deletions
@@ -23,9 +23,11 @@ thiserror = "1.0.26" lto = true [features] -default = ["std", "use-serde", "colors", "address-parse"] +default = ["std", "alloc", "use-serde", "colors", "address-parse"] -std = [] +std = ["alloc"] + +alloc = [] # enables the (optional) use of Serde for bounds on # Arch and Arch::Address |