diff options
author | iximeow <me@iximeow.net> | 2025-04-13 19:09:05 -0700 |
---|---|---|
committer | iximeow <me@iximeow.net> | 2025-04-13 19:09:05 -0700 |
commit | 2a7d0f4dd1b7ec13fa402cf7c18dc9f62e8c4b55 (patch) | |
tree | ed33b45834dfd5e1171218d8cc32edc616049b3e /Cargo.toml | |
parent | 2941adf64a78dbcc67b541c79c94144e7da0fddb (diff) |
seeming good
Diffstat (limited to 'Cargo.toml')
-rw-r--r-- | Cargo.toml | 12 |
1 files changed, 12 insertions, 0 deletions
@@ -12,3 +12,15 @@ edition = "2021" [dependencies] yaxpeax-arch = { version = "0.3.1", default-features = false, features = [] } "num-traits" = { version = "0.2", default-features = false } + +[features] +default = ["std", "fmt"] + +# yaxpeax-arch (and this crate) can drop some featuers and be no-std +std = ["alloc", "yaxpeax-arch/std"] + +# some yaxpeax-arch features require only alloc, not std +alloc = ["yaxpeax-arch/alloc"] + +# regardless of no-std, fmt impls are not necessarily required, and so are optional here +fmt = [] |