summaryrefslogtreecommitdiff
path: root/Cargo.toml
diff options
context:
space:
mode:
authoriximeow <me@iximeow.net>2021-07-21 00:16:57 -0700
committeriximeow <me@iximeow.net>2021-07-21 00:16:57 -0700
commit82bac0e0e2ceebf15b3a70ab0908ffa9df2d0276 (patch)
treecd3e0d1cffd4e29960723461d09db0347d72ffe0 /Cargo.toml
parent210e8d9c682524018b240565465a60f65c288e5d (diff)
fix incorrect changelog entry, DecodeError impl for yaxpeax_arch+std0.2.1
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml8
1 files changed, 7 insertions, 1 deletions
diff --git a/Cargo.toml b/Cargo.toml
index 1738354..b1e7315 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -1,6 +1,6 @@
[package]
name = "yaxpeax-ia64"
-version = "0.2.0"
+version = "0.2.1"
authors = ["iximeow <me@iximeow.net>"]
edition = "2018"
license = "0BSD"
@@ -11,3 +11,9 @@ readme = "README.md"
[dependencies]
yaxpeax-arch = { version = "0.2.2", default-features = false, features = [] }
bitvec = "0.19"
+
+[features]
+default = ["std"]
+
+# opt-in for std-related Error impl - necessary to `?`-unwrap `DecodeError`.
+std = []