diff options
author | iximeow <me@iximeow.net> | 2021-03-13 14:19:55 -0800 |
---|---|---|
committer | iximeow <me@iximeow.net> | 2021-03-13 14:54:47 -0800 |
commit | 93c53657c2289e979672ee6c4612af7e9eac109c (patch) | |
tree | a0acdc143595f64a796827bc849a122dd49cc4e3 /Cargo.toml | |
parent | 6232e8b1daf7067cb2e8065687530d5f88ecb46d (diff) |
split ffi crate to support distinct 16, 32, and 64-bit builds
initial work to optionally discard any instruction printing support
when using `-Z build-std` to fully remove .eh_frame, a stripped
long_mode_no_fmt .so is 61kb!
Diffstat (limited to 'Cargo.toml')
-rw-r--r-- | Cargo.toml | 5 |
1 files changed, 4 insertions, 1 deletions
@@ -33,11 +33,14 @@ opt-level = 3 lto = true [features] -default = ["std", "colors", "use-serde"] +default = ["std", "colors", "use-serde", "fmt"] # opt-in for some apis that are really much nicer with String std = [] +# feature for formatting instructions and their components +fmt = [] + use-serde = ["yaxpeax-arch/use-serde", "serde", "serde_derive"] colors = ["yaxpeax-arch/colors"] |