diff options
author | iximeow <me@iximeow.net> | 2020-01-15 20:04:34 -0800 |
---|---|---|
committer | iximeow <me@iximeow.net> | 2020-01-15 20:04:34 -0800 |
commit | d0e662b146aad03044d933caf2c2c16d7863c5d5 (patch) | |
tree | da8193be5f8a6f105579ce4d0083c9c92132f096 /Cargo.toml | |
parent | a38fe698c2e00a798231ad0ccd984912b593f15a (diff) |
make x86 actually no_std
it depended on crates that dragged in std, oops
Diffstat (limited to 'Cargo.toml')
-rw-r--r-- | Cargo.toml | 10 |
1 files changed, 5 insertions, 5 deletions
@@ -9,11 +9,11 @@ description = "x86 decoders for the yaxpeax project" [dependencies] yaxpeax-arch = { path = "../../yaxpeax-arch", default-features = false, features = []} -"num-traits" = "0.2" -"termion" = "1.4.0" -"serde" = "1.0" -"serde_json" = "1.0" -"serde_derive" = "1.0" +"num-traits" = { version = "0.2", default-features = false } +"termion" = { version = "1.4.0", optional = true } +"serde" = { version = "1.0", optional = true } +"serde_json" = { version = "1.0", optional = true } +"serde_derive" = { version = "1.0", optional = true } [[test]] name = "test" |