aboutsummaryrefslogtreecommitdiff
path: root/Cargo.toml
diff options
context:
space:
mode:
authoriximeow <me@iximeow.net>2019-03-10 17:40:38 -0700
committeriximeow <me@iximeow.net>2020-01-12 16:10:13 -0800
commitfc87dfea6408d378cd5a417f4a5a4dd448df5358 (patch)
treee7351097baecbb4ab532e5e05b4b4356f6eceb90 /Cargo.toml
parent5697c17af9ba0854f37edc5970ec862c446002d2 (diff)
add build configs and tweak lifetimes to match yaxpeax-arch adjustments
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml8
1 files changed, 8 insertions, 0 deletions
diff --git a/Cargo.toml b/Cargo.toml
index 51c590e..27c7f43 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -24,6 +24,14 @@ path = "test/test.rs"
name = "bench"
path = "test/bench.rs"
+[profile.bench]
+opt-level = 3
+lto = true
+
+[profile.release]
+opt-level = 3
+lto = true
+
[features]
default = []