aboutsummaryrefslogtreecommitdiff
path: root/Cargo.toml
diff options
context:
space:
mode:
authoriximeow <me@iximeow.net>2024-06-18 23:37:41 -0700
committeriximeow <me@iximeow.net>2024-06-19 00:05:35 -0700
commit6b0a7aa23f1f125213081cee1f37079e53f05882 (patch)
tree083e6c6bd1a176e5e21af0d6b76cf0225d6c5078 /Cargo.toml
parentcc6f7cabfdd7e48f71241ffc8e4860be6d26ba93 (diff)
configurable inlining to help with opts
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml4
1 files changed, 4 insertions, 0 deletions
diff --git a/Cargo.toml b/Cargo.toml
index e8734cc..34f8af7 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -52,3 +52,7 @@ colors = ["yaxpeax-arch/colors"]
# This enables some capstone benchmarks over the same
# instruction bytes used to bench this code.
capstone_bench = []
+
+# this disables a lot of inlining to make it easier for me to measure
+# likelihood of codepaths for typical instruction sequences
+profiling = []