aboutsummaryrefslogtreecommitdiff
path: root/ffi/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'ffi/Cargo.toml')
-rw-r--r--ffi/Cargo.toml19
1 files changed, 19 insertions, 0 deletions
diff --git a/ffi/Cargo.toml b/ffi/Cargo.toml
new file mode 100644
index 0000000..ff1a4c0
--- /dev/null
+++ b/ffi/Cargo.toml
@@ -0,0 +1,19 @@
+[package]
+name = "yaxpeax_x86_ffi"
+version = "0.0.1"
+authors = ["iximeow <me@iximeow.net>"]
+edition = "2018"
+
+[dependencies]
+yaxpeax-x86 = { path = "../" }
+yaxpeax-arch = { path = "../../../yaxpeax-arch" }
+
+[lib]
+name = "yaxpeax_x86_ffi"
+path = "src/lib.rs"
+crate-type = ["staticlib"]
+
+[profile.release]
+opt-level = 3
+lto = "fat"
+