aboutsummaryrefslogtreecommitdiff
path: root/Cargo.toml
diff options
context:
space:
mode:
authorAndy Wortman <ixineeringeverywhere@gmail.com>2017-09-10 13:04:49 -0700
committerAndy Wortman <ixineeringeverywhere@gmail.com>2017-09-10 13:04:49 -0700
commitecd0be7bc94f86cd85605dd6840a0132b5976126 (patch)
treeb445a550f45ec3b3f879d600d2cc5e701728c7f0 /Cargo.toml
parentcfa1e516a601d00d30a942a7623bbdc0c46ea191 (diff)
support only serializing non-None fields (i hope)
also move application to main thread, twitter connection to.. not main thread. now when twitter fails to connect or the connection drops, the application continues ticking along.
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml2
1 files changed, 2 insertions, 0 deletions
diff --git a/Cargo.toml b/Cargo.toml
index 5d67061..6a0653c 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -27,3 +27,5 @@ hyper-tls = "*"
"serde_json" = "*"
"chan" = "*"
chrono = "0.4"
+serde = "*"
+serde_derive = "*"