aboutsummaryrefslogtreecommitdiff
path: root/Cargo.toml
diff options
context:
space:
mode:
authoriximeow <me@iximeow.net>2021-07-06 11:56:17 -0700
committeriximeow <me@iximeow.net>2021-07-06 15:18:06 -0700
commitca5e4d5d2bdecaebc7da7657cbda2f70a57fdad0 (patch)
tree10d34571ec1416c7b951ae44cff40ce3084a54d2 /Cargo.toml
parent4755f79f91fa4ee27e2626c1202e0ff8fc66f323 (diff)
add ReaderBuilder to generically construct arch-required Readers0.2.2
also revise an `unsafe` that might be unsafe un extremely unlikely circumstances - no one should be passing yaxpeax a `&[u8]` larger than `isize::MAX`, but on 32-bit architectures we can't necessarily guarantee that it won't happen
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml2
1 files changed, 1 insertions, 1 deletions
diff --git a/Cargo.toml b/Cargo.toml
index ae4dbe7..1fc3aff 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -7,7 +7,7 @@ keywords = ["disassembly", "disassembler"]
license = "0BSD"
name = "yaxpeax-arch"
repository = "https://git.iximeow.net/yaxpeax-arch/"
-version = "0.2.1"
+version = "0.2.2"
[dependencies]
"num-traits" = { version = "0.2", default-features = false }