aboutsummaryrefslogtreecommitdiff
path: root/Cargo.toml
diff options
context:
space:
mode:
authoriximeow <me@iximeow.net>2020-05-03 12:29:24 -0700
committeriximeow <me@iximeow.net>2020-05-03 12:31:49 -0700
commitf7449a21140c109567fa6c756dab2b1b0711a414 (patch)
treebebb35a38490d6bcfc9f73c8880b57146cf7a4a7 /Cargo.toml
parent12db880a312d8a4b755bd4139c502405c8011f23 (diff)
add AddressDiff, CHANGELOG, and bump to 0.0.40.0.4
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml5
1 files changed, 3 insertions, 2 deletions
diff --git a/Cargo.toml b/Cargo.toml
index 442a9fa..f72f8ad 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -7,12 +7,13 @@ keywords = ["disassembly", "disassembler"]
license = "0BSD"
name = "yaxpeax-arch"
repository = "https://git.iximeow.net/yaxpeax-arch/"
-version = "0.0.3"
+version = "0.0.4"
[dependencies]
"num-traits" = { version = "0.2", default-features = false }
"termion" = { version = "1.4.0", optional = true }
"serde" = { version = "1.0", optional = true }
+"serde_derive" = { version = "1.0", optional = true }
[profile.release]
lto = true
@@ -22,7 +23,7 @@ default = ["use-serde", "colors", "address-parse"]
# enables the (optional) use of Serde for bounds on
# Arch and Arch::Address
-use-serde = ["serde"]
+use-serde = ["serde", "serde_derive"]
colors = ["termion"]