aboutsummaryrefslogtreecommitdiff
path: root/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml16
1 files changed, 13 insertions, 3 deletions
diff --git a/Cargo.toml b/Cargo.toml
index c6d3cbf..ca47d5b 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -7,7 +7,7 @@ keywords = ["disassembly", "disassembler"]
license = "0BSD"
name = "yaxpeax-arch"
repository = "https://git.iximeow.net/yaxpeax-arch/"
-version = "0.2.8"
+version = "0.3.2"
[dependencies]
"num-traits" = { version = "0.2", default-features = false }
@@ -23,14 +23,24 @@ thiserror = "1.0.26"
lto = true
[features]
-default = ["std", "use-serde", "colors", "address-parse"]
+default = ["std", "alloc", "use-serde", "color-new", "address-parse"]
-std = []
+std = ["alloc"]
+
+alloc = []
# enables the (optional) use of Serde for bounds on
# Arch and Arch::Address
use-serde = ["serde", "serde_derive"]
+# feature flag for the existing but misfeature'd initial support for output
+# coloring. the module this gates will be removed in 0.4.0, which includes
+# removing `trait Colorize`, and requires a major version bump for any
+# dependency that moves forward.
colors = ["crossterm"]
+# feature flag for revised output colorizing support, which will replace the
+# existing `colors` feature in 0.4.0.
+color-new = []
+
address-parse = []