aboutsummaryrefslogtreecommitdiff
path: root/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml14
1 files changed, 9 insertions, 5 deletions
diff --git a/Cargo.toml b/Cargo.toml
index efe935c..f2430f6 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -10,16 +10,20 @@ repository = "https://git.iximeow.net/yaxpeax-arch/"
version = "0.0.1"
[dependencies]
-"num-traits" = "0.2"
-"termion" = "1.4.0"
-"serde" = "1.0"
+"num-traits" = { version = "0.2", default-features = false }
+"termion" = { version = "1.4.0", optional = true }
+"serde" = { version = "1.0", optional = true }
[profile.release]
lto = true
[features]
-default = []
+default = ["use-serde", "colors", "address-parse"]
# enables the (optional) use of Serde for bounds on
# Arch and Arch::Address
-use-serde = []
+use-serde = ["serde"]
+
+colors = ["termion"]
+
+address-parse = []