aboutsummaryrefslogtreecommitdiff
path: root/Cargo.toml
diff options
context:
space:
mode:
authornovafacing <rowanbhart@gmail.com>2024-06-24 13:00:04 -0700
committeriximeow <me@iximeow.net>2024-06-25 14:09:39 -0700
commit739317f268b4ed1a8f3e06af6c6fdf977219d4f9 (patch)
treef5a0f76b7d18063a6d395af516e9b07aafb2bb02 /Cargo.toml
parent997c73be34576fa7cb8c67be5b363498dd82b45d (diff)
Bump yaxpeax-arch and bitvec, allow use of deprecated yaxpeax-arch traits, fix bitvec syntax changes
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml10
1 files changed, 4 insertions, 6 deletions
diff --git a/Cargo.toml b/Cargo.toml
index 5f92713..fbadd4e 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -2,7 +2,7 @@
name = "yaxpeax-arm"
version = "0.2.6"
-authors = [ "iximeow <me@iximeow.net>" ]
+authors = ["iximeow <me@iximeow.net>"]
license = "0BSD"
repository = "http://git.iximeow.net/yaxpeax-arm/"
description = "arm decoders for the yaxpeax project"
@@ -12,13 +12,11 @@ edition = "2018"
[lib]
[workspace]
-members = [
- "differential-tests"
-]
+members = ["differential-tests"]
[dependencies]
-yaxpeax-arch = { version = "0.2.2", default-features = false, features = [] }
-bitvec = "0.19"
+yaxpeax-arch = { version = "0.3.1", default-features = false, features = [] }
+bitvec = "1.0.1"
"serde" = { version = "1.0", optional = true }
"serde_derive" = { version = "1.0", optional = true }