aboutsummaryrefslogtreecommitdiff
path: root/Cargo.toml
diff options
context:
space:
mode:
authoriximeow <me@iximeow.net>2020-01-11 15:20:49 -0800
committeriximeow <me@iximeow.net>2020-01-11 15:20:49 -0800
commit4357d69df98aa1b1de5f94a62fcdc77f6fa1a8c9 (patch)
tree6bc85558e8c9f760a3127cfc03cd7efe3ecdcd12 /Cargo.toml
good morning
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml26
1 files changed, 26 insertions, 0 deletions
diff --git a/Cargo.toml b/Cargo.toml
new file mode 100644
index 0000000..3076334
--- /dev/null
+++ b/Cargo.toml
@@ -0,0 +1,26 @@
+[package]
+name = "yaxpeax-dis"
+version = "0.1.0"
+authors = ["iximeow <me@iximeow.net>"]
+edition = "2018"
+description = "disassembly tool using yaxpeax instruction decoders"
+
+[[bin]]
+name = "yaxdis"
+path = "src/main.rs"
+
+[dependencies]
+clap = "2.33"
+hex = "0.4.0"
+num-traits = "0.2.10"
+
+# common interfaces for all yaxpeax decoders
+yaxpeax-arch = { path = "../yaxpeax-arch" }
+
+yaxpeax-arm = { path = "../arch/arm" }
+yaxpeax-mips = { path = "../arch/mips" }
+yaxpeax-msp430-mc = { path = "../arch/msp430" }
+yaxpeax-pic17 = { path = "../arch/pic17" }
+yaxpeax-pic18 = { path = "../arch/pic18" }
+yaxpeax-pic24 = { path = "../arch/pic24" }
+yaxpeax-x86 = { path = "../arch/x86" }