aboutsummaryrefslogtreecommitdiff
path: root/Cargo.toml
diff options
context:
space:
mode:
authoriximeow <me@iximeow.net>2020-05-03 20:09:38 -0700
committeriximeow <me@iximeow.net>2020-05-03 20:09:38 -0700
commitac4b68ac02c80416197413ac079353c4b60bb6ec (patch)
treee0b93bb2901c926bd338a88e6ed7f6f216fa5beb /Cargo.toml
parent429edb71087f6af043ada99f90d67ca1fb3c97ec (diff)
allow file inputs, update decoders, add avr
"update decoders" here means bump decoders to yaxpeax-arch 0.0.4 versions. additionally, this pulls in fixes in x86 0.0.11 add avr decoder by @The9P4C!!
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml17
1 files changed, 9 insertions, 8 deletions
diff --git a/Cargo.toml b/Cargo.toml
index 24fb857..7ebc2d2 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -17,12 +17,13 @@ hex = "0.4.0"
num-traits = "0.2.10"
# common interfaces for all yaxpeax decoders
-yaxpeax-arch = { version = "0.0.3" }
+yaxpeax-arch = { version = "0.0.4" }
-yaxpeax-arm = { version = "0.0.3" }
-yaxpeax-mips = { version = "0.0.2" }
-yaxpeax-msp430 = { version = "0.0.3" }
-yaxpeax-pic17 = { version = "0.0.2" }
-yaxpeax-pic18 = { version = "0.0.2" }
-yaxpeax-x86 = { version = "0.0.10" }
-yaxpeax-m16c = { version = "0.0.2" }
+yaxpeax-arm = { version = "0.0.4" }
+yaxpeax-avr = { version = "0.0.2" }
+yaxpeax-m16c = { version = "0.0.3" }
+yaxpeax-mips = { version = "0.0.3" }
+yaxpeax-msp430 = { version = "0.0.5" }
+yaxpeax-pic17 = { version = "0.0.3" }
+yaxpeax-pic18 = { version = "0.0.3" }
+yaxpeax-x86 = { version = "0.0.11" }