summaryrefslogtreecommitdiff
path: root/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml31
1 files changed, 31 insertions, 0 deletions
diff --git a/Cargo.toml b/Cargo.toml
new file mode 100644
index 0000000..2e6e1f5
--- /dev/null
+++ b/Cargo.toml
@@ -0,0 +1,31 @@
+[package]
+authors = [ "iximeow <me@iximeow.net>" ]
+description = "instruction decoder for the renesas m16c architecture"
+edition = "2018"
+license = "0BSD"
+name = "yaxpeax-m16c"
+repository = "http://git.iximeow.net/yaxpeax-m16c/"
+version = "0.0.1"
+
+[dependencies]
+yaxpeax-arch = { version = "0.0.2", default-features = false, features = [] }
+"num-traits" = { version = "0.2", default-features = false }
+"serde" = { version = "1.0", optional = true }
+"serde_json" = { version = "1.0", optional = true }
+"serde_derive" = { version = "1.0", optional = true }
+
+[[test]]
+name = "test"
+path = "test/test.rs"
+
+[profile.release]
+opt-level = 3
+lto = true
+
+[features]
+default = ["std", "use-serde"]
+
+# opt-in for some apis that are really much nicer with String
+std = []
+
+use-serde = ["yaxpeax-arch/use-serde", "serde", "serde_derive"]