aboutsummaryrefslogtreecommitdiff
path: root/Cargo.toml
diff options
context:
space:
mode:
authoriximeow <me@iximeow.net>2020-01-15 23:22:18 -0800
committeriximeow <me@iximeow.net>2020-01-15 23:22:18 -0800
commit5ebc7fdd0bb9131aea3c388e6ab7ebd7ce9ebc00 (patch)
treeeace1ad3799d07a37f1909017862c97c8312c4b6 /Cargo.toml
parent10b7f6d581f04b284a8308d4c1c82a59dae36a6b (diff)
make space for non-64bit modes
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml4
1 files changed, 2 insertions, 2 deletions
diff --git a/Cargo.toml b/Cargo.toml
index 295428f..65fcb55 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -8,7 +8,7 @@ repository = "http://git.iximeow.net/yaxpeax-x86/"
description = "x86 decoders for the yaxpeax project"
[dependencies]
-yaxpeax-arch = { path = "../../yaxpeax-arch", default-features = false, features = []}
+yaxpeax-arch = { path = "../../yaxpeax-arch", default-features = false, features = [] }
"num-traits" = { version = "0.2", default-features = false }
"termion" = { version = "1.4.0", optional = true }
"serde" = { version = "1.0", optional = true }
@@ -37,7 +37,7 @@ default = ["std", "colors", "use-serde"]
# opt-in for some apis that are really much nicer with String
std = []
-use-serde = ["yaxpeax-arch/use-serde"]
+use-serde = ["yaxpeax-arch/use-serde", "serde", "serde_derive"]
colors = ["yaxpeax-arch/colors"]