aboutsummaryrefslogtreecommitdiff
path: root/Cargo.toml
diff options
context:
space:
mode:
authoriximeow <me@iximeow.net>2020-01-15 01:17:42 -0800
committeriximeow <me@iximeow.net>2020-01-15 01:17:42 -0800
commitc03917812aa6ce5a731d743298cb2ab46627189a (patch)
tree698d38f653a44fb3cf4dfba688db67c36ba3fe61 /Cargo.toml
parentb7ac0d56035dda259d9c666c03bc70ace5e58f41 (diff)
no_std!!
this makes yaxpeax-x86 no_std. no externally-visible changes!
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml13
1 files changed, 9 insertions, 4 deletions
diff --git a/Cargo.toml b/Cargo.toml
index 7931af4..a6b96b9 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -8,7 +8,7 @@ repository = "http://git.iximeow.net/yaxpeax-x86/"
description = "x86 decoders for the yaxpeax project"
[dependencies]
-yaxpeax-arch = { path = "../../yaxpeax-arch" }
+yaxpeax-arch = { path = "../../yaxpeax-arch", default-features = false, features = []}
"num-traits" = "0.2"
"termion" = "1.4.0"
"serde" = "1.0"
@@ -32,10 +32,15 @@ opt-level = 3
lto = true
[features]
-default = []
+default = ["std", "colors", "use-serde"]
+
+# opt-in for some apis that are really much nicer with String
+std = []
+
+use-serde = ["yaxpeax-arch/use-serde"]
+
+colors = ["yaxpeax-arch/colors"]
# This enables some capstone benchmarks over the same
# instruction bytes used to bench this code.
capstone_bench = []
-
-use-serde = []