aboutsummaryrefslogtreecommitdiff
path: root/ffi/Cargo.toml
diff options
context:
space:
mode:
authoriximeow <me@iximeow.net>2020-01-12 15:03:09 -0800
committeriximeow <me@iximeow.net>2020-01-12 16:10:14 -0800
commit825eabe868163189d371901ecfe27b4a3d0c9e97 (patch)
treef6240281710fe5971a7b28de3f3277402bd6eb0f /ffi/Cargo.toml
parentb7b781db7a2ba94c816ff5138a713114c39d4034 (diff)
add *extremely* poor ffi bindings for x86 decoders
this is specifically to support a disas-bench integration, for now
Diffstat (limited to 'ffi/Cargo.toml')
-rw-r--r--ffi/Cargo.toml19
1 files changed, 19 insertions, 0 deletions
diff --git a/ffi/Cargo.toml b/ffi/Cargo.toml
new file mode 100644
index 0000000..ff1a4c0
--- /dev/null
+++ b/ffi/Cargo.toml
@@ -0,0 +1,19 @@
+[package]
+name = "yaxpeax_x86_ffi"
+version = "0.0.1"
+authors = ["iximeow <me@iximeow.net>"]
+edition = "2018"
+
+[dependencies]
+yaxpeax-x86 = { path = "../" }
+yaxpeax-arch = { path = "../../../yaxpeax-arch" }
+
+[lib]
+name = "yaxpeax_x86_ffi"
+path = "src/lib.rs"
+crate-type = ["staticlib"]
+
+[profile.release]
+opt-level = 3
+lto = "fat"
+