aboutsummaryrefslogtreecommitdiff
path: root/ffi/Cargo.toml
diff options
context:
space:
mode:
authoriximeow <me@iximeow.net>2021-03-13 14:19:55 -0800
committeriximeow <me@iximeow.net>2021-03-13 14:54:47 -0800
commit93c53657c2289e979672ee6c4612af7e9eac109c (patch)
treea0acdc143595f64a796827bc849a122dd49cc4e3 /ffi/Cargo.toml
parent6232e8b1daf7067cb2e8065687530d5f88ecb46d (diff)
split ffi crate to support distinct 16, 32, and 64-bit builds
initial work to optionally discard any instruction printing support when using `-Z build-std` to fully remove .eh_frame, a stripped long_mode_no_fmt .so is 61kb!
Diffstat (limited to 'ffi/Cargo.toml')
-rw-r--r--ffi/Cargo.toml26
1 files changed, 11 insertions, 15 deletions
diff --git a/ffi/Cargo.toml b/ffi/Cargo.toml
index e009a38..6914779 100644
--- a/ffi/Cargo.toml
+++ b/ffi/Cargo.toml
@@ -1,19 +1,15 @@
-[package]
-name = "yaxpeax_x86_ffi"
-version = "0.0.2"
-authors = ["iximeow <me@iximeow.net>"]
-edition = "2018"
-
-[dependencies]
-yaxpeax-x86 = { path = "../", default-features = false }
-yaxpeax-arch = { version = "0.0.4", default-features = false, features = [] }
-
-[lib]
-name = "yaxpeax_x86_ffi"
-path = "src/lib.rs"
-crate-type = ["staticlib"]
+[profile.dev]
+lto = "fat"
+panic = "abort"
[profile.release]
-opt-level = 3
lto = "fat"
panic = "abort"
+
+[workspace]
+members = [
+ "multiarch",
+ "long_mode",
+ "protected_mode",
+ "real_mode",
+]