aboutsummaryrefslogtreecommitdiff
path: root/ffi/protected_mode/Cargo.toml
diff options
context:
space:
mode:
authoriximeow <me@iximeow.net>2021-03-22 23:15:18 -0700
committeriximeow <me@iximeow.net>2021-03-22 23:40:20 -0700
commiteb870634d6d08b437f7773e99aadb97cf3fdba26 (patch)
treefb866d78f85c1d5587a47fc9b708ff2f52be2377 /ffi/protected_mode/Cargo.toml
parent0fff2a6aa0832b1cabf381e0c970f0fd47223224 (diff)
port long-mode ffi to protected-mode
Diffstat (limited to 'ffi/protected_mode/Cargo.toml')
-rw-r--r--ffi/protected_mode/Cargo.toml7
1 files changed, 6 insertions, 1 deletions
diff --git a/ffi/protected_mode/Cargo.toml b/ffi/protected_mode/Cargo.toml
index 9c0e03a..95e8bf4 100644
--- a/ffi/protected_mode/Cargo.toml
+++ b/ffi/protected_mode/Cargo.toml
@@ -11,4 +11,9 @@ yaxpeax-arch = { version = "0.0.4", default-features = false }
[lib]
name = "yaxpeax_x86_ffi_protected_mode"
path = "src/lib.rs"
-crate-type = ["staticlib"]
+crate-type = ["staticlib", "cdylib"]
+
+[features]
+default = ["fmt"]
+
+fmt = ["yaxpeax-x86/fmt"]