aboutsummaryrefslogtreecommitdiff
path: root/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml13
1 files changed, 12 insertions, 1 deletions
diff --git a/Cargo.toml b/Cargo.toml
index b18575d..51c590e 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -1,6 +1,6 @@
[package]
-name = "x86-rs"
+name = "yaxpeax-x86"
version = "0.0.1"
authors = [ "iximeow <me@iximeow.net>" ]
repository = "x86-rs"
@@ -19,3 +19,14 @@ A rust x86-64 decoder
[[test]]
name = "test"
path = "test/test.rs"
+
+[[bench]]
+name = "bench"
+path = "test/bench.rs"
+
+[features]
+default = []
+
+# This enables some capstone benchmarks over the same
+# instruction bytes used to bench this code.
+capstone_bench = []