aboutsummaryrefslogtreecommitdiff
path: root/ffi/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'ffi/Cargo.toml')
-rw-r--r--ffi/Cargo.toml26
1 files changed, 11 insertions, 15 deletions
diff --git a/ffi/Cargo.toml b/ffi/Cargo.toml
index e009a38..6914779 100644
--- a/ffi/Cargo.toml
+++ b/ffi/Cargo.toml
@@ -1,19 +1,15 @@
-[package]
-name = "yaxpeax_x86_ffi"
-version = "0.0.2"
-authors = ["iximeow <me@iximeow.net>"]
-edition = "2018"
-
-[dependencies]
-yaxpeax-x86 = { path = "../", default-features = false }
-yaxpeax-arch = { version = "0.0.4", default-features = false, features = [] }
-
-[lib]
-name = "yaxpeax_x86_ffi"
-path = "src/lib.rs"
-crate-type = ["staticlib"]
+[profile.dev]
+lto = "fat"
+panic = "abort"
[profile.release]
-opt-level = 3
lto = "fat"
panic = "abort"
+
+[workspace]
+members = [
+ "multiarch",
+ "long_mode",
+ "protected_mode",
+ "real_mode",
+]