aboutsummaryrefslogtreecommitdiff
path: root/Cargo.toml
diff options
context:
space:
mode:
authoriximeow <me@iximeow.net>2021-07-03 21:55:23 -0700
committeriximeow <me@iximeow.net>2021-07-03 21:55:23 -0700
commit288ab8fa823d2fbe567e60253c8bad9b2c9b7fd4 (patch)
tree51d3fd061bc5199f85503353e178c7f56cc228b5 /Cargo.toml
parentb49987bdbd2b5a08163a45ef3dc1868754d84165 (diff)
support std::error::Error
included is mandataing a `description` method on `DecodeError` implementors - already approximately required by the Debug and Display anyway. also include a StandardPartialDecoderError for incomplete decoders to use. i expect that one of the last steps of a decoder's 1.0 release will be to move away from this.
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml8
1 files changed, 7 insertions, 1 deletions
diff --git a/Cargo.toml b/Cargo.toml
index cb49e90..7674eb8 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -15,11 +15,17 @@ version = "0.0.5"
"serde" = { version = "1.0", optional = true }
"serde_derive" = { version = "1.0", optional = true }
+[dev-dependencies]
+"anyhow" = "*"
+"thiserror" = "*"
+
[profile.release]
lto = true
[features]
-default = ["use-serde", "colors", "address-parse"]
+default = ["std", "use-serde", "colors", "address-parse"]
+
+std = []
# enables the (optional) use of Serde for bounds on
# Arch and Arch::Address