aboutsummaryrefslogtreecommitdiff
path: root/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml8
1 files changed, 7 insertions, 1 deletions
diff --git a/Cargo.toml b/Cargo.toml
index cb49e90..7674eb8 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -15,11 +15,17 @@ version = "0.0.5"
"serde" = { version = "1.0", optional = true }
"serde_derive" = { version = "1.0", optional = true }
+[dev-dependencies]
+"anyhow" = "*"
+"thiserror" = "*"
+
[profile.release]
lto = true
[features]
-default = ["use-serde", "colors", "address-parse"]
+default = ["std", "use-serde", "colors", "address-parse"]
+
+std = []
# enables the (optional) use of Serde for bounds on
# Arch and Arch::Address