aboutsummaryrefslogtreecommitdiff
path: root/Cargo.toml
diff options
context:
space:
mode:
authoriximeow <me@iximeow.net>2019-04-21 14:16:44 -0700
committeriximeow <me@iximeow.net>2020-01-12 16:26:39 -0800
commitcd2881ff02ae5c90bf459581df9dcdef1535ab23 (patch)
tree9ff33787099656a342a033509b19bfbb07312d19 /Cargo.toml
parent9e2e1a1bc0f0a03e03a6e370ce91536bc2443774 (diff)
awful tweaks to expose a serde flag on yaxpeax-arch which will trickle through everything
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml8
1 files changed, 8 insertions, 0 deletions
diff --git a/Cargo.toml b/Cargo.toml
index 005384f..3436931 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -10,6 +10,14 @@ description = "fundamental traits to describe an architecture in the yaxpeax pro
[dependencies]
"num-traits" = "0.2"
"termion" = "1.4.0"
+"serde" = "*"
[profile.release]
lto = true
+
+[features]
+default = []
+
+# enables the (optional) use of Serde for bounds on
+# Arch and Arch::Address
+use-serde = []