aboutsummaryrefslogtreecommitdiff
path: root/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml8
1 files changed, 8 insertions, 0 deletions
diff --git a/Cargo.toml b/Cargo.toml
index 005384f..3436931 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -10,6 +10,14 @@ description = "fundamental traits to describe an architecture in the yaxpeax pro
[dependencies]
"num-traits" = "0.2"
"termion" = "1.4.0"
+"serde" = "*"
[profile.release]
lto = true
+
+[features]
+default = []
+
+# enables the (optional) use of Serde for bounds on
+# Arch and Arch::Address
+use-serde = []