aboutsummaryrefslogtreecommitdiff
path: root/Cargo.toml
diff options
context:
space:
mode:
authoriximeow <me@iximeow.net>2019-04-21 14:17:00 -0700
committeriximeow <me@iximeow.net>2020-01-12 17:28:07 -0800
commit0ef3cdf12d5a5087bf95e1d8820723536a28a0cf (patch)
tree4ad5cbf9d1f454e96e5a559bb294b39727cf91d3 /Cargo.toml
parent00aa1ab7515f7dee7dcdfc28b3f942c30671677a (diff)
awful tweaks to expose a serde flag on yaxpeax-arch which will trickle through everything
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml7
1 files changed, 7 insertions, 0 deletions
diff --git a/Cargo.toml b/Cargo.toml
index d9f2b9c..641c3dc 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -11,6 +11,8 @@ A rust arm decoder
[dependencies]
yaxpeax-arch = { path = "../../yaxpeax-arch" }
+"serde" = "*"
+"serde_derive" = "*"
[[test]]
name = "test"
@@ -19,3 +21,8 @@ path = "test/test.rs"
[[bench]]
name = "bench"
path = "test/test.rs"
+
+[features]
+default = []
+
+use-serde = []