aboutsummaryrefslogtreecommitdiff
path: root/tests/no_std_check/Cargo.toml
diff options
context:
space:
mode:
authoriximeow <me@iximeow.net>2025-02-06 00:19:11 -0800
committeriximeow <me@iximeow.net>2025-02-06 00:19:11 -0800
commite2b05ce19c48f34b0fbf3661a6079157eff26fa7 (patch)
tree6ff9ff50f4ab091db1963a9a13b4643d4e421723 /tests/no_std_check/Cargo.toml
parent9822e508fd7653f0a8b3c0c5dd3222c24cc09821 (diff)
actually check no-std configuration does not transitively depend on std
Diffstat (limited to 'tests/no_std_check/Cargo.toml')
-rw-r--r--tests/no_std_check/Cargo.toml24
1 files changed, 24 insertions, 0 deletions
diff --git a/tests/no_std_check/Cargo.toml b/tests/no_std_check/Cargo.toml
new file mode 100644
index 0000000..f5ad827
--- /dev/null
+++ b/tests/no_std_check/Cargo.toml
@@ -0,0 +1,24 @@
+[package]
+
+name = "no-std-test"
+version = "0.0.1"
+authors = ["iximeow <me@iximeow.net>"]
+license = "0BSD"
+description = "test crate to check that yaxpeax-arm is actually no-stds"
+edition = "2021"
+publish = false
+
+[[bin]]
+name = "no-std-test"
+path = "src/main.rs"
+
+[profile.dev]
+panic = "abort"
+
+[profile.release]
+panic = "abort"
+
+[dependencies]
+yaxpeax-arm = { path = "../..", default-features = false }
+
+[workspace]