aboutsummaryrefslogtreecommitdiff
path: root/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml7
1 files changed, 5 insertions, 2 deletions
diff --git a/Cargo.toml b/Cargo.toml
index 54a13b1..00fd5ae 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -1,7 +1,7 @@
[package]
name = "yaxpeax-arm"
-version = "0.1.0"
+version = "0.1.1"
authors = [ "iximeow <me@iximeow.net>" ]
license = "0BSD"
repository = "http://git.iximeow.net/yaxpeax-arm/"
@@ -19,6 +19,9 @@ name = "test"
path = "test/test.rs"
[features]
-default = ["use-serde"]
+default = ["std", "use-serde"]
+
+# opt-in for std-related Error impl - necessary to `?`-unwrap `DecodeError`.
+std = []
use-serde = ["yaxpeax-arch/use-serde", "serde", "serde_derive"]