aboutsummaryrefslogtreecommitdiff
path: root/Cargo.toml
diff options
context:
space:
mode:
authoriximeow <me@iximeow.net>2022-01-03 14:06:57 -0800
committeriximeow <me@iximeow.net>2022-01-03 14:06:57 -0800
commit0759de116479c8a6319450e1e116af39e8c844c5 (patch)
tree38b806c8c3035faf99c88ada34bb7eab4309c4e3 /Cargo.toml
parentc9a266cd62713f2ff7f5cf637adafd685ee17f16 (diff)
parentfe9c41db5e4f2916439dd268a1b5e65447396ce3 (diff)
architecture-generic bit layouts of instructions
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml10
1 files changed, 7 insertions, 3 deletions
diff --git a/Cargo.toml b/Cargo.toml
index ee63e0f..2cc050c 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -13,23 +13,27 @@ readme = "README.md"
name = "yaxdis"
path = "src/main.rs"
+[patch.crates-io]
+yaxpeax-arch-02 = { package = "yaxpeax-arch", path = "/toy/yaxpeax/yaxpeax-arch/" }
+
[dependencies]
clap = "2.33"
hex = "0.4.0"
num-traits = "0.2.10"
+itertools = "0.10.1"
# common interfaces for all yaxpeax decoders
-yaxpeax-arch-02 = { package = "yaxpeax-arch", version = "0.2.4" }
+yaxpeax-arch-02 = { package = "yaxpeax-arch", version = "0.2.4" , default-features = false, features = ["std"] }
yaxpeax-arm = { version = "0.2.3" }
yaxpeax-avr = { version = "0.1.0" }
yaxpeax-m16c = { version = "0.1.0" }
yaxpeax-mips = { version = "0.1.0" }
-yaxpeax-msp430 = { version = "0.1.0" }
+yaxpeax-msp430 = { version = "0.1.0", path = "/toy/yaxpeax/arch/msp430" }
yaxpeax-lc87 = { version = "1.0.0" }
yaxpeax-pic17 = { version = "0.1.0" }
yaxpeax-pic18 = { version = "0.1.0" }
-yaxpeax-x86 = { version = "1.1.3" }
+yaxpeax-x86 = { version = "1.1.3", default-features = false, features = ["fmt", "std"] }
yaxpeax-ia64 = { version = "0.2.1" }
yaxpeax-superh = { version = "0.3.0" }
yaxpeax-6502 = { version = "0.0.2", features = ["std"] }