aboutsummaryrefslogtreecommitdiff
path: root/Cargo.toml
diff options
context:
space:
mode:
authoriximeow <me@iximeow.net>2021-07-21 00:19:36 -0700
committeriximeow <me@iximeow.net>2021-07-21 00:38:12 -0700
commit754f28d76c6c0def07561337969699accb843423 (patch)
tree2ae3ce6e7a71d41b061c6e75affc4c238ea91756 /Cargo.toml
parent12ee099cad10cf93948239bb4b44966d60ffc8af (diff)
update decoders to yaxpeax_arch 0.2 versions, add lc87 and x86_16
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml26
1 files changed, 14 insertions, 12 deletions
diff --git a/Cargo.toml b/Cargo.toml
index 525623d..c9897e3 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -1,6 +1,6 @@
[package]
name = "yaxpeax-dis"
-version = "0.2.4"
+version = "0.2.5"
authors = ["iximeow <me@iximeow.net>"]
license = "0BSD"
edition = "2018"
@@ -19,16 +19,18 @@ hex = "0.4.0"
num-traits = "0.2.10"
# common interfaces for all yaxpeax decoders
-yaxpeax-arch = { version = "0.0.5" }
+yaxpeax-arch-02 = { package = "yaxpeax-arch", version = "0.2.4" }
+yaxpeax-arch-01 = { package = "yaxpeax-arch", version = "0.0.5" }
-yaxpeax-arm = { version = "0.0.7" }
-yaxpeax-avr = { version = "0.0.3" }
-yaxpeax-m16c = { version = "0.0.4" }
-yaxpeax-mips = { version = "0.0.4" }
-yaxpeax-msp430 = { version = "0.0.6" }
-yaxpeax-pic17 = { version = "0.0.4" }
-yaxpeax-pic18 = { version = "0.0.4" }
-yaxpeax-x86 = { version = "0.2.0" }
-yaxpeax-ia64 = { version = "0.1.4" }
-yaxpeax-superh = { version = "0.1.1" }
+yaxpeax-arm = { version = "0.1.1" }
+yaxpeax-avr = { version = "0.1.0" }
+yaxpeax-m16c = { version = "0.1.0" }
+yaxpeax-mips = { version = "0.1.0" }
+yaxpeax-msp430 = { version = "0.1.0" }
+yaxpeax-lc87 = { version = "1.0.0" }
+yaxpeax-pic17 = { version = "0.1.0" }
+yaxpeax-pic18 = { version = "0.1.0" }
+yaxpeax-x86 = { version = "1.0.3" }
+yaxpeax-ia64 = { version = "0.2.1" }
+yaxpeax-superh = { version = "0.1.0" }
yaxpeax-6502 = { version = "0.0.1" }