aboutsummaryrefslogtreecommitdiff
path: root/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml17
1 files changed, 9 insertions, 8 deletions
diff --git a/Cargo.toml b/Cargo.toml
index 3076334..69c038a 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -2,6 +2,7 @@
name = "yaxpeax-dis"
version = "0.1.0"
authors = ["iximeow <me@iximeow.net>"]
+license = "0BSD"
edition = "2018"
description = "disassembly tool using yaxpeax instruction decoders"
@@ -15,12 +16,12 @@ hex = "0.4.0"
num-traits = "0.2.10"
# common interfaces for all yaxpeax decoders
-yaxpeax-arch = { path = "../yaxpeax-arch" }
+yaxpeax-arch = { version = "0.0.3" }
-yaxpeax-arm = { path = "../arch/arm" }
-yaxpeax-mips = { path = "../arch/mips" }
-yaxpeax-msp430-mc = { path = "../arch/msp430" }
-yaxpeax-pic17 = { path = "../arch/pic17" }
-yaxpeax-pic18 = { path = "../arch/pic18" }
-yaxpeax-pic24 = { path = "../arch/pic24" }
-yaxpeax-x86 = { path = "../arch/x86" }
+yaxpeax-arm = { version = "0.0.2" }
+yaxpeax-mips = { version = "0.0.2" }
+yaxpeax-msp430 = { version = "0.0.3" }
+yaxpeax-pic17 = { version = "0.0.2" }
+yaxpeax-pic18 = { version = "0.0.2" }
+yaxpeax-x86 = { version = "0.0.4" }
+yaxpeax-m16c = { version = "0.0.2" }