aboutsummaryrefslogtreecommitdiff
path: root/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml16
1 files changed, 10 insertions, 6 deletions
diff --git a/Cargo.toml b/Cargo.toml
index 1751d14..ab69d41 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -13,24 +13,28 @@ readme = "README.md"
name = "yaxdis"
path = "src/main.rs"
+[patch.crates-io]
+yaxpeax-arch-02 = { package = "yaxpeax-arch", path = "/toy/yaxpeax/yaxpeax-arch/" }
+
[dependencies]
clap = "2.33"
hex = "0.4.0"
num-traits = "0.2.10"
+itertools = "0.10.1"
# common interfaces for all yaxpeax decoders
-yaxpeax-arch-02 = { package = "yaxpeax-arch", version = "0.2.4" }
-yaxpeax-arch-01 = { package = "yaxpeax-arch", version = "0.0.5" }
+yaxpeax-arch-02 = { package = "yaxpeax-arch", version = "0.2.4" , default-features = false, features = ["std"] }
+yaxpeax-arch-01 = { package = "yaxpeax-arch", version = "0.0.5" , default-features = false }
-yaxpeax-arm = { version = "0.1.1" }
+yaxpeax-arm = { version = "0.1.1", default-features = false, features = ["std"] }
yaxpeax-avr = { version = "0.1.0" }
yaxpeax-m16c = { version = "0.1.0" }
yaxpeax-mips = { version = "0.1.0" }
-yaxpeax-msp430 = { version = "0.1.0" }
+yaxpeax-msp430 = { version = "0.1.0", path = "/toy/yaxpeax/arch/msp430" }
yaxpeax-lc87 = { version = "1.0.0" }
yaxpeax-pic17 = { version = "0.1.0" }
yaxpeax-pic18 = { version = "0.1.0" }
-yaxpeax-x86 = { version = "1.0.4" }
-yaxpeax-ia64 = { version = "0.2.1" }
+yaxpeax-x86 = { version = "1.1.0", default-features = false, features = ["fmt", "std"] }
+yaxpeax-ia64 = { version = "0.2.1", path = "/toy/yaxpeax/arch/ia64" }
yaxpeax-superh = { version = "0.1.0" }
yaxpeax-6502 = { version = "0.0.1" }