aboutsummaryrefslogtreecommitdiff
path: root/Cargo.toml
diff options
context:
space:
mode:
authoriximeow <me@iximeow.net>2017-09-10 13:04:49 -0700
committeriximeow <me@iximeow.net>2017-09-10 13:04:49 -0700
commit4415a995272b97dd7774a0b071218878f6c450f4 (patch)
treeb445a550f45ec3b3f879d600d2cc5e701728c7f0 /Cargo.toml
parent93a6501938cc5ae8ffb3b2b8c08f77a80ddef086 (diff)
support only serializing non-None fields (i hope)
also move application to main thread, twitter connection to.. not main thread. now when twitter fails to connect or the connection drops, the application continues ticking along.
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml2
1 files changed, 2 insertions, 0 deletions
diff --git a/Cargo.toml b/Cargo.toml
index 5d67061..6a0653c 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -27,3 +27,5 @@ hyper-tls = "*"
"serde_json" = "*"
"chan" = "*"
chrono = "0.4"
+serde = "*"
+serde_derive = "*"